View Issue Details

IDProjectCategoryView StatusLast Update
12514Development [All Projects] Expression Managerpublic2020-02-27 10:47
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version3.x 
Target VersionFixed in Version4.0.0dev 
Summary12514: Add an new setKnowVar public function in EM
Description

I think it's great if we can extend 'replacement' part : replace or add new KEYWORD
(i attach related bug some minute after)

But we try to remove event , then it's seems the best way is just to add :

  1. A public function setKnowVar($var as string, $value=null as string|null)
  2. Add it in LimesurveyApi
Steps To Reproduce

Some idea where this can be used:

  1. Condition depend on browser : hide some question for phone (for example)
  2. Condition depend on other response (quota for example, see https://framagit.org/SondagePro-LimeSurvey-plugin/getStatInSurvey for basic idea)
  3. Show list of previous answer easily
Additional Information

Easys
If $var didn't exist : create it in readWrite->N mode (https://github.com/LimeSurvey/LimeSurvey/blob/develop/application/helpers/expressions/em_manager_helper.php#L3642)
If $var exist and is a "fixed var" : update code

if $var exist and is a dynamic var ( answer in fact) allow updating the actual value ? In DB + in $_SESSION ?

TagsNo tags attached.

Relationships

duplicate of 14206 resolvedDenisChenu Feature requests Allow plugin to update expression knowVars 
related to 15873 resolvedollehar Bug reports setVariableExpressionEnd have lack of system to udate question part 

Activities

DenisChenu

DenisChenu

2017-07-04 17:31

developer   ~44046

Last edited: 2017-07-04 17:32

View 2 revisions

@olle , @LouisGac any advice ? Point of view ?

DenisChenu

DenisChenu

2017-07-04 17:42

developer   ~44048

Sorry : it's really another way to fix the duplicate

Issue History

Date Modified Username Field Change
2017-07-04 17:30 DenisChenu New Issue
2017-07-04 17:31 DenisChenu Note Added: 44046
2017-07-04 17:32 DenisChenu Note Edited: 44046 View Revisions
2017-07-04 17:39 DenisChenu Relationship added related to 11432
2017-07-04 17:39 DenisChenu Relationship replaced duplicate of 11432
2017-07-04 17:42 DenisChenu Status new => closed
2017-07-04 17:42 DenisChenu Resolution open => duplicate
2017-07-04 17:42 DenisChenu Note Added: 44048
2019-09-07 11:02 DenisChenu Assigned To => DenisChenu
2019-09-07 11:02 DenisChenu Status closed => feedback
2019-09-07 11:02 DenisChenu Resolution duplicate => reopened
2019-09-07 11:02 DenisChenu Relationship added duplicate of 14206
2019-09-07 11:02 DenisChenu Relationship deleted 11432
2019-09-07 11:03 DenisChenu Status feedback => resolved
2019-09-07 11:03 DenisChenu Resolution reopened => duplicate
2019-09-07 11:03 DenisChenu Fixed in Version => 4.0.0dev
2019-09-07 11:03 DenisChenu Status resolved => closed
2020-02-27 10:47 DenisChenu Relationship added related to 15873