View Issue Details

IDProjectCategoryView StatusLast Update
11680Development Templatespublic2018-02-16 15:54
ReporterDenisChenuAssigned ToDenisChenu 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version2.5x 
Target Version3.xFixed in Version3.x 
Summary11680: label in table : visible-xs-block or sr-only
Description

Actually , for the label-text inside table : we use visible-xs-block : there are 2 issues :

  • Without no-more-table : it's broken
  • And the display none !important; is awfull for accessibility.

Actually : i move to sr-only: it's OK for the 2 issue before, but not easy to understand for template designer.

Steps To Reproduce

HUe , look at code ....

Additional Information

Maybe need a specific class by LS core : in fact i think have a limesurvey-core.css the most little possible allow us to use :

  • ls-visible-xs (for example) with a class accessible and hidden in md/lg
  • no-more-table by default for all answers table.

Any advice ?

Final : ls-label-xs-visibility

Tagsanswers_html

Activities

DenisChenu

DenisChenu

2016-10-05 00:37

developer   ~41133

[16:31] <LouisGac> " ls-label-in-cell-can-be-shown-in-xs-if-templet-want-it " :-D
[16:31] <shnoulle> It's not accessibiloity here (because this part is easy to use sr-only in place of hidden)
[16:31] <Tammo> And document, so no other developer will revert it without having deep thoughts about it...
[16:31] <LouisGac> yep good point
[16:32] <shnoulle> Tammo : yes : and must documentg than removing ls-core css package can broke template with minor release number
[16:32] <shnoulle> Then we can fix more easily template/js/css in minor release
[16:33] <LouisGac> I'm thinking about the " ls-label-in-cell-can-be-shown-in-xs-if-templet-want-it ", and I think it's a good solution (with a shorter name of course)
[16:33] <Tammo> ls-label-optional?
[16:33] <shnoulle> Give me the name : i put the css in core.css
[16:34] <shnoulle> limesurvey.css
[16:34] <Tammo> ls-label-xs-optional
[16:34] <shnoulle> because name help dev :)
[16:34] <LouisGac> maybe rather: ls-label-xs-visibility
[16:35] <LouisGac> so it's obvious you can set it to shown/hidden
[16:36] <Tammo> OK by me
[16:36] <shnoulle> Great :)

Then : ls-label-xs-visibility

Related Changesets

LimeSurvey: answers_html 86aeba89

2016-10-05 17:42:28

DenisChenu

Details Diff
Dev issue 11680 : replace sr-only by ls-label-xs-visibility
Dev: tested on base_awesome + default with same template-core for all aray
Affected Issues
11449, 11680
mod - application/core/packages/limesurvey/ls-public.css Diff File
mod - application/helpers/qanda_helper.php Diff File
mod - application/views/survey/questions/arrays/10point/rows/cells/answer_td_input.php Diff File
mod - application/views/survey/questions/arrays/5point/rows/cells/answer_td_input.php Diff File
mod - application/views/survey/questions/arrays/array/no_dropdown/rows/cells/answer_td.php Diff File
mod - application/views/survey/questions/arrays/dualscale/answer.php Diff File
mod - application/views/survey/questions/arrays/dualscale/answer_dropdown.php Diff File
mod - application/views/survey/questions/arrays/increasesamedecrease/rows/answer_row.php Diff File
mod - application/views/survey/questions/arrays/multiflexi/rows/answer_row.php Diff File
mod - application/views/survey/questions/arrays/multiflexi/rows/cells/answer_td.php Diff File
mod - application/views/survey/questions/arrays/multiflexi/rows/cells/answer_td_checkboxes.php Diff File
mod - application/views/survey/questions/arrays/texts/rows/cells/answer_td.php Diff File
mod - application/views/survey/questions/arrays/yesnouncertain/rows/answer_row.php Diff File
rm - templates/base/css/bootstrap-ls.css Diff File
rm - templates/base/css/jquery-ui-fix.css Diff File
rm - templates/base/css/limesurvey.css Diff File
mod - templates/base/css/template.css Diff File
mod - templates/base_awesome/css/template-core.css Diff File
mod - templates/base_awesome/pstpl/question.pstpl Diff File
mod - templates/default/css/template-core.css Diff File

Issue History

Date Modified Username Field Change
2016-09-18 19:13 DenisChenu New Issue
2016-09-19 10:45 DenisChenu Tag Attached: answers_html
2016-10-05 00:33 DenisChenu Assigned To => DenisChenu
2016-10-05 00:33 DenisChenu Status new => assigned
2016-10-05 00:37 DenisChenu Note Added: 41133
2016-10-05 00:37 DenisChenu Additional Information Updated View Revisions
2016-10-05 17:45 DenisChenu Changeset attached => LimeSurvey answers_html 86aeba89
2016-10-05 17:45 DenisChenu Status assigned => resolved
2016-10-05 17:45 DenisChenu Resolution open => fixed
2016-10-05 17:45 DenisChenu Fixed in Version => 3.x
2018-02-16 15:54 c_schmitz Status resolved => closed