View Revisions: Issue #17658

Summary 17658: When exporting survey statistics containing a map (Google Maps or OpenStreetMap), the map is not in the exported file
Revision 2021-10-13 10:25 by galads
Steps To Reproduce Steps to reproduce
------------------------------
1) Create a survey with at least a "Short Free Text" question type;
2) Enable on "Location" section map service OpenStreetMap or Google Maps (i haven't used Maps because i can't get an API key);
3) Enable on "Stats" section "Display map" and "Display chart";
4) Save, close, activate survey and do it;
5) With at least 1 response in that survey, come back to survey settings and go on "Statistics";
6) On "Output options" section, enable "Show graphs", then select PDF "Output format", then select all questions in "Response filters" and, in the end, click "Export images".

Expected result
-------------------------
I was expecting a PDF with a map with pins.

Actual result
-----------------
I saw only data tables and graphs.

Revision 2021-10-11 18:16 by koxife
Steps To Reproduce Steps to reproduce
------------------------------
1) Create a survey with at least a "Short Free Text" question type;
2) Enable on "Location" section map service OpenStreetMap or Google Maps (i haven't used Maps because i can't get an API key);
3) Enable on "Stats" section "Display map" and "Display chart";
4) Save, close, activate survey and do it;
5) With at least 1 response in that survey, come back to survey settings and go on "Statistics";
6) On "Output options" section, enable "Show graphs", then select PDF "Output format", then select all questions in "Response filters" and, in the end, click "Export images".

Expected result
-------------------------
I was expecting a PDF with a map with pins.

Actual result
-----------------
I saw only data tables and graphs.