View Revisions: Issue #17586

Summary 17586: Opening new browser tabs using question index leads to inputted data being deleted
Revision 2021-09-09 12:55 by Mazi
Description In a survey that allows for full navigation back/forth using the question index, opening the different pages at new browser tabs leads to problems. If you have entered data at several pages of the survey and then move back and forth to validate your input, you might find it handy to open a new tab of your browser, showing the selected group (open the link in a new tab, while pointing to the navbar menu item). But: This clears all input of all items in the landing page - at least when it is the same page that is open already!

The tricky thing is that navigating with Next/Back-Buttons and opening new survey instances using the same token, Limesurvey recognizes this and takes care of the data in each page. So I think, the navigation-link behaviour is a bug.
Revision 2021-09-09 12:28 by Mazi
Description In a survey that allows for full navigation back/forth using the question index, opening the different pages at new browser tabs leads to problems. If you have entered data at several pages of the survey and then move back and forth to validate your input, you might find it handy to open a new tab of your browser, showing the selected group (open the link in a new tab, while pointing to the navbar menu item). But: This clears all input of all items in the landing page - at least when it is the same page that is open already!

The tricky thing is that navigating with Next/Back-Buttons and opening new survey instances using the same token, Limesurvey recognizes this and takes care of the data in each page. So I think, the navigation-link behaviour is a bug.