View Revisions: Issue #15919

Summary 15919: Cannot import custom question theme based on an array question
Revision 2020-02-26 19:00 by tpartner
Description When I try importing the attached question theme (which works in 3.x), I get an error:

file_get_contents(C:\xampp\htdocs\limeSurvey4x\upload/themes/question/Adjustable-Semantic-Diff-Array/survey/questions/answer/array\config.xml): failed to open stream: No such file or directory

This appears to be because the system is not looking for the full path to find the config file in an array question which is like this (from 3.x and also the path in the 4.x views):

/upload/themes/question/yourThemeName/survey/questions/answer/**arrays**/array/config.xml
Revision 2020-02-26 18:58 by tpartner
Description When I try importing the attached question theme (which works in 3.x), I get an error:

file_get_contents(C:\xampp\htdocs\limeSurvey4x\upload/themes/question/Adjustable-Semantic-Diff-Array/survey/questions/answer/array\config.xml): failed to open stream: No such file or directory

This appears to be because the system is not looking for the full path to find the config file in an array question which is like this (from 3.x and also the path in the 4.x views):

/upload/themes/question/yourThemeName/survey/questions/answer/**arrays**/array/
Revision 2020-02-26 18:57 by tpartner
Description When I try importing the attached question theme (which works in 3.x), I get an error:

//file_get_contents(C:\xampp\htdocs\limeSurvey4x\upload/themes/question/Adjustable-Semantic-Diff-Array/survey/questions/answer/array\config.xml): failed to open stream: No such file or directory//

This appears to be because the system is not looking for the full path to find the config file in an array question which is like this (from 3.x and also the path in the 4.x views):

/upload/themes/question/yourThemeName/survey/questions/answer/**arrays**/array/
Revision 2020-02-26 18:57 by tpartner
Description When I try importing the attached question theme (which works in 3.x), I get an error:

<code>file_get_contents(C:\xampp\htdocs\limeSurvey4x\upload/themes/question/Adjustable-Semantic-Diff-Array/survey/questions/answer/array\config.xml): failed to open stream: No such file or directory </code>

This appears to be because the system is not looking for the full path to find the config file in an array question which is like this (from 3.x and also the path in the 4.x views):

/upload/themes/question/yourThemeName/survey/questions/answer/**arrays**/array/
Revision 2020-02-26 18:56 by tpartner
Description When I try importing the attached question theme (which works in 3.x), I get an error:

  file_get_contents(C:\xampp\htdocs\limeSurvey4x\upload/themes/question/Adjustable-Semantic-Diff-Array/survey/questions/answer/array\config.xml): failed to open stream: No such file or directory

This appears to be because the system is not looking for the full path to find the config file in an array question which is like this (from 3.x and also the path in the 4.x views):

/upload/themes/question/yourThemeName/survey/questions/answer/**arrays**/array/