View Revisions: Issue #12869

Summary 12869: Auth plugin must have a Permission settings accessible via GUI
Revision 2017-11-05 22:05 by digitmaster
Description

The view "application/views/admin/user/editusers.php" is rendered only if the AuthLDAP plugin is active because the plugin name is hardcoded. This makes issues the development of plugins using LDAP because it is not possible for such plugins to add users using LDAP search.
I found this one by myself exacltly while developing the plugin:
https://github.com/digitmaster/limesurveyplugins/tree/master/LowercaseAuthLDAP
which is working in my production intranet site with the patched view.

Pull request:
https://github.com/LimeSurvey/LimeSurvey/pull/852

Revision 2017-11-05 21:19 by digitmaster
Description

The view "application/views/admin/user/editusers.php" is rendered only if the AuthLDAP plugin is active because the plugin name is hardcoded. This makes issues the development of plugins using LDAP because it is not possible for such plugins to add users using LDAP search.
I found this one by myself exacltly while developing the plugin:
https://github.com/digitmaster/limesurveyplugins/tree/master/LowercaseAuthLDAP
which is working in my production intranet site with the patched view.

Pull request:
https://github.com/digitmaster/LimeSurvey/commit/800f8fc63484e780d39501340953eba6696281ff