LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08997Bug reports[All Projects] Installationpublic2014-04-24 10:572014-05-02 15:10
Reportersteve_81 
Assigned Tosammousa 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version2.05+ 
Target VersionFixed in Version2.05+ 
Summary08997: DB connection failed with newest release of xampp (20140422)
DescriptionI installed the newest version of limesurvey (xampp). Everything worked fine with the installation. But after the installation: if I go to localhost/ an error occured:

Internal Server Error
CDbConnection failed to open the DB connection.

Obviously other users in the forum and IRC Chat have the same problem.

In the Cotrol Panel: apache and MySql show "Running". I don't no if this matters bute the apache workes only after I started the beta version of the panel.
Steps To ReproduceI uninstalled xampp completly and installed again, but the same problem occured.

The latest available unstable version of xampp (20131125) works better (no prob with DB connection) until the point where you enter the login -> login not correct (I guess thats the reason for the latest release)
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit IDxampp 2.05plus 20140422
BrowserFF
Database & DB-Versionxampp
Operating System (Server)xampp
Webserver software & versionxampp
PHP Versionxampp
Attached Files

- Relationships

-  Notes
User avatar (29873)
Mazi (developer)
2014-04-24 11:27

This issue was reported twice at the Limesurvey IRC today and there is also a forum topic about it: http://www.limesurvey.org/en/forum/installation-a-update-issues/95814-installed-the-xampp-package-but-cant-log-in-as-an-admin-to-the-local-host [^]
User avatar (29876)
c_schmitz (administrator)
2014-04-25 09:51

Sam, the install command is currently not working at all. Can you give it a check and if it works from your point of view please assign it back to me and I will crosscheck?
User avatar (29896)
sammousa (developer)
2014-04-27 23:25

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=14190 [^]
User avatar (29950)
c_schmitz (administrator)
2014-05-02 15:10

2.05+ Build 140502 released.

- Related Changesets
LimeSurvey: master 77e736c9
Timestamp: 2014-04-27 21:25:28
Author: sammousa
Committer: Sam Mousa
Details ] Diff ]
Fixed issue 08997
mod - application/commands/InstallCommand.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-04-24 10:57 steve_81 New Issue
2014-04-24 11:27 Mazi Note Added: 29873
2014-04-25 09:25 c_schmitz Assigned To => c_schmitz
2014-04-25 09:25 c_schmitz Status new => assigned
2014-04-25 09:50 c_schmitz Assigned To c_schmitz => sammousa
2014-04-25 09:51 c_schmitz Note Added: 29876
2014-04-27 23:25 sammousa Changeset attached => LimeSurvey master 77e736c9
2014-04-27 23:25 sammousa Note Added: 29896
2014-04-27 23:25 sammousa Resolution open => fixed
2014-04-27 23:25 sammousa Assigned To sammousa => c_schmitz
2014-05-02 09:45 c_schmitz Status assigned => resolved
2014-05-02 09:45 c_schmitz Fixed in Version => 2.05+
2014-05-02 09:45 c_schmitz Assigned To c_schmitz => sammousa
2014-05-02 15:10 c_schmitz Note Added: 29950
2014-05-02 15:10 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker