LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
08875Bug reports[All Projects] Survey takingpublic2014-03-19 12:522014-06-26 09:34
Reportertpartner 
Assigned Toc_schmitz 
PriorityhighSeveritymajor 
StatusclosedResolutionfixed 
Product Version2.05+ 
Target Version2.05+Fixed in Version2.05+ 
Summary08875: Data is being stored for unanswered Array dual scale (dropdown) question
DescriptionThe unanswered selects in an Array dual scale (dropdown) question no longer have the "Please choose" option and if the page is submitted the first option is recorded as an answer even if the respondent does nothing.
Steps To Reproduce- Import and activate the attached survey.
- Execute the survey and move to group 2 without touching any of the selects in group 1.
- Check the data and you will see answers recorded even though the selects were not touched.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID490134bba9
BrowserN/A
Database & DB-VersionN/A
Operating System (Server)Win 32
Webserver software & versionApache/2.4.3 (Win32)
PHP Version5.4.7
Attached Files? file icon limesurvey_survey_883124.lss [^] (20,328 bytes) 2014-03-19 12:52
? file icon limesurvey_survey_191976.lss [^] (18,255 bytes) 2014-06-23 16:40
png file icon Capture du 2014-06-23 16:42:42.png [^] (27,277 bytes) 2014-06-23 16:43

- Relationships
related to 09117closedDenisChenu Array dual scale (dropdown) question : First answer is allways selected is SHow no answer is false 

-  Notes
User avatar (29442)
c_schmitz (administrator)
2014-03-20 14:24

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=14050 [^]
User avatar (29443)
c_schmitz (administrator)
2014-03-20 14:52

2.05+ Build 140320 released
User avatar (30211)
DenisChenu (developer)
2014-06-23 16:39
edited on: 2014-06-23 16:44

Reopened : because the first answer is already checked if question is mandatory

See attached survey (showing difference with a single choice).

Carsten : you can assign it to me : here there are a lack of control of 'already answered' quesion:

if (SHOW_NO_ANSWER == 1)

must be
if (SHOW_NO_ANSWER == 1 || !isset($_SESSION['survey_'.Yii::app()->getConfig('surveyID')][$myfname0]) )

(and same for second scale).

PS: i can open a new with 'Mandatory Dual scale with dropdown layout : 1st answer is automatically set.

User avatar (30232)
DenisChenu (developer)
2014-06-26 09:34

Open a new bug and take it : http://bugs.limesurvey.org/view.php?id=9117 [^]

- Related Changesets
LimeSurvey: master d9bd41da
Timestamp: 2014-03-20 13:24:05
Author: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 08875: 'No answer' not available in Dual Scale dropdown even when 'No answer' is set to show
mod - application/helpers/qanda_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-03-19 12:52 tpartner New Issue
2014-03-19 12:52 tpartner File Added: limesurvey_survey_883124.lss
2014-03-19 13:23 c_schmitz Assigned To => c_schmitz
2014-03-19 13:23 c_schmitz Status new => assigned
2014-03-20 14:24 c_schmitz Changeset attached => LimeSurvey master d9bd41da
2014-03-20 14:24 c_schmitz Note Added: 29442
2014-03-20 14:24 c_schmitz Resolution open => fixed
2014-03-20 14:25 c_schmitz Status assigned => resolved
2014-03-20 14:25 c_schmitz Fixed in Version => 2.05+
2014-03-20 14:52 c_schmitz Note Added: 29443
2014-03-20 14:52 c_schmitz Status resolved => closed
2014-06-23 16:39 DenisChenu Note Added: 30211
2014-06-23 16:39 DenisChenu Status closed => feedback
2014-06-23 16:39 DenisChenu Resolution fixed => reopened
2014-06-23 16:40 DenisChenu File Added: limesurvey_survey_191976.lss
2014-06-23 16:43 DenisChenu File Added: Capture du 2014-06-23 16:42:42.png
2014-06-23 16:44 DenisChenu Note Edited: 30211 View Revisions
2014-06-26 09:34 DenisChenu Relationship added related to 09117
2014-06-26 09:34 DenisChenu Note Added: 30232
2014-06-26 09:34 DenisChenu Status feedback => closed
2014-06-26 09:34 DenisChenu Resolution reopened => fixed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker