LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
07828Feature requests[All Projects] RemoteControlpublic2013-05-13 03:022013-06-05 09:46
Reporterbebs 
Assigned Tomdekker 
PrioritynormalSeverity@50@ 
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary07828: export_responses does not respect "lang" parameter
Descriptionexporting full questions with remote control export_responses does not consider the "language" setting for the user questions, but only for the first "system" questions/tokens.


If I export the full questions (and not only code), the question labels are not that in the selected lang but that of the default survey language.... but for the few first (system) items that are indeed translated (completed, tokens...).

sample code & survey attached.


Additional InformationThe attached survey and code are directly deployed at http://misc.resilientweb.eu/render/lang-test.php [^] for a short period of time.

view in source mode to see the first 3 items of the FR and EN exports are indeed translated according to selected language, and the other (user questions) are not translated in the export... whereas they are in the survey (see lss).

If there is any way to export the translated questions labels as a workaround I'm interested too... as long as it can be mapped onto its related question code.

thanks.
TagsNo tags attached.
Attached Files? file icon limesurvey_survey_73983.lss [^] (57,680 bytes) 2013-05-13 03:02
? file icon lang-test.php [^] (1,743 bytes) 2013-05-13 03:05

- Relationships
duplicate of 07869closedmdekker Bug reports export_responses result as always in the default language 

-  Notes
User avatar (25227)
bebs (reporter)
2013-05-13 03:04

sample working code (simply update your connection details and include http://api.limesurvey.org/Unspecified/jsonRPCClient.html [^])

check it out directly at http://misc.resilientweb.eu/render/lang-test.php [^] (for a short period of time)
User avatar (25240)
trougakoss (developer)
2013-05-14 12:37

I will look into it...
User avatar (25468)
mdekker (developer)
2013-06-05 09:46

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=12526 [^]

- Related Changesets
LimeSurvey: 2.05 0c226cd3
Timestamp: 2013-06-05 07:03:00
Author: mdekker
Committer: Menno Dekker
Details ] Diff ]
Fixed 07828: export_responses does not respect "lang" parameter
mod - application/helpers/admin/export/ExcelWriter.php Diff ] File ]
mod - application/helpers/admin/export/PdfWriter.php Diff ] File ]
mod - application/helpers/admin/export/SurveyDao.php Diff ] File ]
mod - application/helpers/admin/exportresults_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-05-13 03:02 bebs New Issue
2013-05-13 03:02 bebs File Added: limesurvey_survey_73983.lss
2013-05-13 03:04 bebs Note Added: 25227
2013-05-13 03:05 bebs File Added: lang-test.php
2013-05-14 12:10 Mazi Assigned To => trougakoss
2013-05-14 12:10 Mazi Status new => assigned
2013-05-14 12:37 trougakoss Note Added: 25240
2013-06-02 19:00 c_schmitz Relationship added duplicate of 07869
2013-06-02 19:00 c_schmitz Status assigned => closed
2013-06-02 19:00 c_schmitz Resolution open => duplicate
2013-06-05 09:46 mdekker Changeset attached => LimeSurvey 2.05 0c226cd3
2013-06-05 09:46 mdekker Note Added: 25468
2013-06-05 09:46 mdekker Assigned To trougakoss => mdekker
2013-06-05 09:46 mdekker Resolution duplicate => fixed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker