LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
07309Bug reports[All Projects] Survey takingpublic2013-02-16 22:432013-03-11 15:04
ReporterMazi 
Assigned ToDenisChenu 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target Version2.00+Fixed in Version2.00+ 
Summary07309: Placeholders referring to dual scale question do not work
DescriptionWhen using a dual scale question and displaying the results at a following question using placeholders, then this doesn't work if questions are on the same page.
Steps To Reproduce1. Import the attached survey.
2. Run it in group by group mode
-> Placeholders do not work
3. Switch to question by question mode -> everything works fine.
Additional InformationSame problem seems to show up when using radio buttons instead of the drop down layout.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID130213
BrowserChrome
Database & DB-VersionMySQL 5
Operating System (Server)Windows 7
Webserver software & versionApache 2.2
PHP Version5.3.1
Attached Files? file icon limesurvey_survey_467752-Dual_Scale_Problem.lss [^] (46,618 bytes) 2013-02-16 22:43
? file icon limesurvey_survey_467752.lss [^] (46,730 bytes) 2013-03-01 16:57

- Relationships
child of 04638closedDenisChenu Development  Array Dual Scale - Dual Dropdown - id contains # 

-  Notes
User avatar (24134)
c_schmitz (administrator)
2013-02-17 09:54

It does not work here in dropdown or radio. It is a problem that cannot be fixed easily because of the illegal field naming for dual scale questions.
User avatar (24149)
Mazi (developer)
2013-02-19 11:12

This is a rather serious issue since it holds one of my customer off launching a large and complex survey which should start in 5-7 days, so I would be very happy about a short term fix.

Let me know if I can help with testing or if you need additional information.
User avatar (24167)
DenisChenu (developer)
2013-02-19 12:40

It's an EM issue, and like all EM issue, it's hard to debug.

A quick possible javascript workaround:
- delegate a click function to td for table.question
- in this click function :
-- check the line clicked and get the sub question
-- check the input:radio:checked index and get the head with same index (the answers)
-> Doing own replacment

This don't use the id, then think it can work.

It's not the EM way, then it's a workaround.
User avatar (24185)
DenisChenu (developer)
2013-02-21 11:31

Reminder sent to: Mazi

I have it, but actually it break min answers and max answers.

Mazi: can you try min answer and max answer on this question type and see if it's OK or not.

If it's not OK, i pull/close this one and put a new bug for min_answers and max_answers (and surely some other attributes)
User avatar (24186)
Mazi (developer)
2013-02-21 12:17

It seems that there is another bug with min and max answers, see http://limesurvey-templates.com/20/index.php/survey/index/sid/922399/newtest/Y/lang/en [^]
User avatar (24189)
DenisChenu (developer)
2013-02-21 12:26

OK,

Then it don't work actually with min/max .

Cool, pushing it this evening and i put another bug for min/max :)
User avatar (24190)
Mazi (developer)
2013-02-21 13:06

Great, thanks a lot!
User avatar (24192)
DenisChenu (developer)
2013-02-21 20:00

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=11667 [^]
User avatar (24194)
DenisChenu (developer)
2013-02-21 20:06

Yeah !

I'm happy ...

Tested:
EM epxression in another question
Filter array for array_dual and from array_dual
min_answers and ma_answers
{self.sq_0} ans {self.sq_SQ001}

I rework a little the HTML and move whole js in external files. Just to remove the input hidden for EM in javascript to. Think this input can be competely removed with a better ExprMgr_process_relevance_and_tailoring function.

Denis.
PS: Mazi : can you do some test please ?
User avatar (24196)
Mazi (developer)
2013-02-22 09:53

Thanks for your work, Denis.

I can't test right now because my dev system is currently broken. I hope to fix this next week.

Maybe Carsten can have a short look!?
User avatar (24291)
Mazi (developer)
2013-02-26 15:21

Denis, did the placeholders for dual scale questions change?

See this test survey: http://limesurvey-templates.com/20/index.php/survey/index/sid/467752/newtest/Y/lang/de [^]

The month is replaced correctly but the year is not shown. For the month {Dual_1_0.shown} is used which works fine, for the year {Dual_1_1.shown} is used which does NOT work.

Any ideas?
User avatar (24292)
DenisChenu (developer)
2013-02-26 16:05

Can you test with an letter in the subQ.

Because EM don't make difference betwwen _1 for scale and _1 for answer.

The Dual_A1_1 can be better
User avatar (24293)
Mazi (developer)
2013-02-26 16:17

I have changed the subquestion code from 1 to sq1 but this didn't solve the problem: http://limesurvey-templates.com/20/index.php/survey/index/sid/467752/newtest/Y/lang/de [^]

I also changed the scale codes to a1,a2,a3... and b1,b2,b3...
User avatar (24294)
Mazi (developer)
2013-02-26 16:27

Weird, at this survey it seems to work fine: http://limesurvey-templates.com/20/index.php/survey/index/sid/922399/newtest/Y/lang/en [^]
User avatar (24427)
DenisChenu (developer)
2013-02-27 02:18

Mazi:

Can you export this one:
http://limesurvey-templates.com/20/index.php/survey/index/sid/467752/newtest/Y/lang/de [^]

Please
User avatar (24430)
TMSWhite (reporter)
2013-02-27 06:04

Mazi and Denis-

For reference, the originally attached survey works fine in the final version of 1.92. The use of '#' in name and id attributes was fine there. There must have been some changes in 2.0 that introduced incompatibility with that naming.

I recommend regression testing these changes against all of the test surveys in /demos/surveys to ensure everything still works properly. For example, numeric scale codes should work (and used to work in 1.92). If these changes require that authors change to use scale codes like a1, a2, a3, instead of 1,2,3, then this set of fixes have introduced a regression.
User avatar (24456)
Mazi (developer)
2013-03-01 16:57

Requested survey attached.
User avatar (24556)
DenisChenu (developer)
2013-03-05 15:31

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=11776 [^]
User avatar (24574)
c_schmitz (administrator)
2013-03-07 22:39

Fix committed to 2.05 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=11793 [^]
User avatar (24627)
c_schmitz (administrator)
2013-03-11 15:04

2.00+ build 130311 released

- Related Changesets
LimeSurvey: master 9c0ce00e
Timestamp: 2013-02-21 18:56:07
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 07309: Placeholders referring to dual scale question do not work
Fixed issue 04638: Array Dual Scale - Dual Dropdown - id contains #
Dev: remove # in answer id, but leave it in name: no need table updating like this
Dev: remove # in EM input name (hidden id="java....")
Dev: Lauch ExprMgr_process_relevance_and_tailoring in external javascript (think it's the way to do)
Dev: some fix for specific attributes in array_dual
Dev: all to be redone for 2.1/Plugin ...
mod - application/helpers/expressions/em_manager_helper.php Diff ] File ]
mod - application/helpers/qanda_helper.php Diff ] File ]
add - scripts/dualscale.js Diff ] File ]
mod - scripts/survey_runtime.js Diff ] File ]
LimeSurvey: master 9f934f2d
Timestamp: 2013-03-05 14:27:44
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 07309: Placeholders referring to dual scale question do not work
Dev: lost some match in em javascript
mod - scripts/expressions/em_javascript.js Diff ] File ]
LimeSurvey: 2.05 7aca4ab7
Timestamp: 2013-03-05 14:27:44
Author: DenisChenu
Committer: c_schmitz
Committer: Carsten Schmitz
Details ] Diff ]
Fixed issue 07309: Placeholders referring to dual scale question do not work
Dev: lost some match in em javascript
mod - scripts/expressions/em_javascript.js Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-02-16 22:43 Mazi New Issue
2013-02-16 22:43 Mazi Status new => assigned
2013-02-16 22:43 Mazi Assigned To => c_schmitz
2013-02-16 22:43 Mazi File Added: limesurvey_survey_467752-Dual_Scale_Problem.lss
2013-02-17 09:54 c_schmitz Note Added: 24134
2013-02-18 22:08 DenisChenu Relationship added child of 04638
2013-02-18 22:11 DenisChenu Assigned To c_schmitz => DenisChenu
2013-02-19 11:12 Mazi Note Added: 24149
2013-02-19 12:40 DenisChenu Note Added: 24167
2013-02-21 11:31 DenisChenu Note Added: 24185
2013-02-21 12:17 Mazi Note Added: 24186
2013-02-21 12:26 DenisChenu Note Added: 24189
2013-02-21 13:06 Mazi Note Added: 24190
2013-02-21 20:00 DenisChenu Changeset attached => LimeSurvey master 9c0ce00e
2013-02-21 20:00 DenisChenu Note Added: 24192
2013-02-21 20:00 DenisChenu Resolution open => fixed
2013-02-21 20:06 DenisChenu Note Added: 24194
2013-02-21 20:06 DenisChenu Status assigned => resolved
2013-02-21 20:06 DenisChenu Fixed in Version => 2.00+
2013-02-22 09:53 Mazi Note Added: 24196
2013-02-26 15:21 Mazi Note Added: 24291
2013-02-26 15:22 Mazi Status resolved => assigned
2013-02-26 16:05 DenisChenu Note Added: 24292
2013-02-26 16:17 Mazi Note Added: 24293
2013-02-26 16:27 Mazi Note Added: 24294
2013-02-27 02:18 DenisChenu Note Added: 24427
2013-02-27 06:04 TMSWhite Note Added: 24430
2013-03-01 16:57 Mazi File Added: limesurvey_survey_467752.lss
2013-03-01 16:57 Mazi Note Added: 24456
2013-03-05 15:31 DenisChenu Changeset attached => LimeSurvey master 9f934f2d
2013-03-05 15:31 DenisChenu Note Added: 24556
2013-03-05 15:32 DenisChenu Status assigned => resolved
2013-03-07 22:39 c_schmitz Changeset attached => LimeSurvey 2.05 7aca4ab7
2013-03-07 22:39 c_schmitz Note Added: 24574
2013-03-11 15:04 c_schmitz Note Added: 24627
2013-03-11 15:04 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker