LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
07185Bug reports[All Projects] Survey designpublic2013-01-14 13:582013-01-23 16:29
ReporterpfpDave 
Assigned Toc_schmitz 
PrioritynormalSeverityminor 
StatusclosedResolutionunable to reproduce 
Product Version2.00+ 
Target VersionFixed in Version 
Summary07185: Adding a large number of answer options to a drop down list won't work with no error
DescriptionI'm trying to add 386 answer options to a drop down list (Job Titles). Clicking Quick Add amd Replace shows the titles listed, I can save as a label set and this works but when I click save, it tells me it's saved the options against the question (Answer options were successfully saved.) but removes them all and leaves only the 'Some example answer option' entry.

Replicated in FireFox 18
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID130108
BrowserIE8
Database & DB-VersionSQL Express 2012
Operating System (Server)Server 2008
Webserver software & versionIIS 7
PHP Version5.4.8
Attached Files? file icon limesurvey_labelset_41.lsl [^] (106,812 bytes) 2013-01-18 16:40

- Relationships

-  Notes
User avatar (23641)
pfpDave (reporter)
2013-01-14 14:04

Additionally, I wrote this script to work around the issue (pull from saved label set), and then edited through the UI, clicking save removed all options and left the 'some example answer option':

INSERT INTO answers (qid, code, answer, sortorder, assessment_value,language, scale_id)
SELECT 433, code, title, sortorder,assessment_value, language, 0 from labels where
lid = 41;
User avatar (23645)
c_schmitz (administrator)
2013-01-14 16:06

Can you attach the labelset please?
User avatar (23704)
pfpDave (reporter)
2013-01-18 16:40

Attached as requested, sorry for the delay
User avatar (23741)
c_schmitz (administrator)
2013-01-22 13:13

This works fine here. I think it is a server misconfiguration that limits the maximum number of POST fields that can be posted in one go.

See max_input_vars on PHP.
User avatar (23777)
pfpDave (reporter)
2013-01-23 13:16

This (max_input_vars) is set to 1000 on my server, what value should it be?
User avatar (23778)
c_schmitz (administrator)
2013-01-23 13:38

Depends how big your label sets get. Double it, save, restart the webserver, then try again.

- Issue History
Date Modified Username Field Change
2013-01-14 13:58 pfpDave New Issue
2013-01-14 14:04 pfpDave Note Added: 23641
2013-01-14 16:06 c_schmitz Note Added: 23645
2013-01-14 16:06 c_schmitz Assigned To => c_schmitz
2013-01-14 16:06 c_schmitz Status new => feedback
2013-01-18 16:40 pfpDave File Added: limesurvey_labelset_41.lsl
2013-01-18 16:40 pfpDave Note Added: 23704
2013-01-18 16:40 pfpDave Status feedback => assigned
2013-01-22 13:13 c_schmitz Note Added: 23741
2013-01-22 13:13 c_schmitz Status assigned => closed
2013-01-22 13:13 c_schmitz Resolution open => unable to reproduce
2013-01-23 13:16 pfpDave Note Added: 23777
2013-01-23 13:16 pfpDave Status closed => feedback
2013-01-23 13:16 pfpDave Resolution unable to reproduce => reopened
2013-01-23 13:38 c_schmitz Note Added: 23778
2013-01-23 16:29 c_schmitz Status feedback => closed
2013-01-23 16:29 c_schmitz Resolution reopened => unable to reproduce


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker