LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
06949Bug reports[All Projects] Tokenspublic2012-11-24 18:002012-12-04 13:16
Reporterjelo 
Assigned ToDenisChenu 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version2.00+ 
Target VersionFixed in Version2.00+ 
Summary06949: Expressions are not replaced with their values in quota urls / screens
DescriptionIf you use token attributes the variables won't be replaced with the values in quota screen / url.
Additional InformationThread:
http://www.limesurvey.org/de/forum/can-i-do-this-with-limesurvey/88568-token-attribute-field-in-url-field [^]

Version 2.00+ Build 121121
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID121121
BrowserFirefox
Database & DB-VersionMySQL
Operating System (Server)Linux Centos 6.3 ( 3.2.24-x86_64 )
Webserver software & versionApache/2.2.23
PHP Version5.3.18
Attached Files? file icon limesurvey_survey_527515.lss [^] (31,279 bytes) 2012-12-02 22:46

- Relationships

-  Notes
User avatar (22791)
DenisChenu (developer)
2012-12-01 23:56
edited on: 2012-12-01 23:56

It's OK for end url ?

Can you provide a simple lss example file ?

User avatar (22799)
jelo (reporter)
2012-12-02 09:41
edited on: 2012-12-02 09:42

EndURL on the last page was not tested by me.

I tested the QuotaURL screens (since that was asked in the thread).
The was no replacement of the variables.
Did that worked for you?

I add this bug ticket after reading the thread of the original finder of this bug.
I have asked him to follow up and offer an example lss.

User avatar (22801)
jelo (reporter)
2012-12-02 10:42

The bugtracker is public. The attached survey can be downloaded. I would remove most of the survey and upload a striped down version first.
Even if you can made posts private you cannot be sure on the internet.
So might revoke the file now before too many people downloaded it.
User avatar (22805)
DenisChenu (developer)
2012-12-02 18:53

Deleted, but i jusst ask a simple lss example file : less think to do (5/10 mminutes ;) )
User avatar (22809)
DenisChenu (developer)
2012-12-03 03:34

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=10656 [^]
User avatar (22810)
DenisChenu (developer)
2012-12-03 03:34

OK for 2.0, waiting for 2.1
User avatar (22813)
jelo (reporter)
2012-12-03 09:09

Since I got all the deleted notes as well I am a bit confused.
Is the bug confirmed for 2.0?

What is meant by "OK for 2.0"?
User avatar (22814)
DenisChenu (developer)
2012-12-03 09:26

jelo,

Sorry, but at start i redo a test survey but i forgot to put my question in quota .... then when i make test all is OK, because i don't go to quota.

After, i add my question, and test and ALL expresion are not replaced in quota urls and message.

The patch http://bugs.limesurvey.org/plugin.php?page=Source/view&id=10656 [^] is for 2.0 only, then closed for LS 2.0, but not for 2.1 .

Denis
User avatar (22815)
jelo (reporter)
2012-12-03 09:50

Thanks,

Version 2.0 - Patch available
Version 2.1 - Pending

Question for the average user is: Will the next comfort update be from the 2.1 or 2.0 branch?
User avatar (22816)
DenisChenu (developer)
2012-12-03 09:51
edited on: 2012-12-03 09:51

2.0

I don't patch actually 2.1 because there are some other big and more difficult patch.

User avatar (22828)
DenisChenu (developer)
2012-12-03 17:26

Fix committed to 2.1 branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=10675 [^]
User avatar (22829)
cvandermeij (reporter)
2012-12-03 18:11

Hi guys, thanks for your work. Am I correct to say that this issue will be resolved once I upgrade to the latest version of Limesurvey?
User avatar (22831)
DenisChenu (developer)
2012-12-03 19:03

For the next auto update, yes
User avatar (22844)
c_schmitz (administrator)
2012-12-04 13:16

LimeSurvey 2.0+ build 121204 released.

- Related Changesets
LimeSurvey: master 1a4c840f
Timestamp: 2012-12-03 02:32:21
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 06949: Expressions are not replaced with their values in quota urls / screens
mod - application/helpers/frontend_helper.php Diff ] File ]
LimeSurvey: 2.1 15f9c0a5
Timestamp: 2012-12-03 16:24:10
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Fixed issue 06949: Expressions are not replaced with their values in quota urls / screens
mod - application/helpers/frontend_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-11-24 18:00 jelo New Issue
2012-11-30 16:00 c_schmitz Assigned To => c_schmitz
2012-11-30 16:00 c_schmitz Status new => assigned
2012-12-01 23:11 c_schmitz Assigned To c_schmitz => DenisChenu
2012-12-01 23:56 DenisChenu Note Added: 22791
2012-12-01 23:56 DenisChenu Note Edited: 22791 View Revisions
2012-12-02 09:41 jelo Note Added: 22799
2012-12-02 09:42 jelo Note Edited: 22799 View Revisions
2012-12-02 10:07 cvandermeij File Added: limesurvey_survey_948181.lss
2012-12-02 10:42 jelo Note Added: 22801
2012-12-02 18:53 DenisChenu File Deleted: limesurvey_survey_948181.lss
2012-12-02 18:53 DenisChenu Note Added: 22805
2012-12-02 22:46 cvandermeij File Added: limesurvey_survey_527515.lss
2012-12-03 02:38 DenisChenu Note Added: 22807
2012-12-03 02:40 DenisChenu Note Deleted: 22807
2012-12-03 02:40 DenisChenu Note Added: 22808
2012-12-03 03:32 DenisChenu Summary Token attributes variables are not replaced with their values in quota urls / screens => Variables are not replaced with their values in quota urls / screens
2012-12-03 03:32 DenisChenu Summary Variables are not replaced with their values in quota urls / screens => Expressions are not replaced with their values in quota urls / screens
2012-12-03 03:34 DenisChenu Changeset attached => LimeSurvey master 1a4c840f
2012-12-03 03:34 DenisChenu Note Added: 22809
2012-12-03 03:34 DenisChenu Resolution open => fixed
2012-12-03 03:34 DenisChenu Note Deleted: 22808
2012-12-03 03:34 DenisChenu Note Added: 22810
2012-12-03 09:09 jelo Note Added: 22813
2012-12-03 09:26 DenisChenu Note Added: 22814
2012-12-03 09:50 jelo Note Added: 22815
2012-12-03 09:51 DenisChenu Note Added: 22816
2012-12-03 09:51 DenisChenu Note Edited: 22816 View Revisions
2012-12-03 17:26 DenisChenu Changeset attached => LimeSurvey 2.1 15f9c0a5
2012-12-03 17:26 DenisChenu Note Added: 22828
2012-12-03 17:26 DenisChenu Status assigned => resolved
2012-12-03 17:26 DenisChenu Fixed in Version => 2.00+
2012-12-03 18:11 cvandermeij Note Added: 22829
2012-12-03 19:03 DenisChenu Note Added: 22831
2012-12-04 13:16 c_schmitz Note Added: 22844
2012-12-04 13:16 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker