LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
06319Bug reports[All Projects] Survey designpublic2012-07-11 20:492012-08-16 10:35
ReporterDenisChenu 
Assigned ToDenisChenu 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version1.92+ 
Target VersionFixed in Version2.00RC9 
Summary06319: Previewing group can throw error
DescriptionIf you preview a group just after create it (and some question), then you have a error page:

Notice: Undefined index: language in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/index.php on line 1666 Notice: Undefined index: usecaptcha in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/index.php on line 1673 Notice: Undefined index: language in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/index.php on line 2010 Notice: Undefined index: name in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/replacements.php on line 735

This survey does not yet have any questions and cannot be tested or completed.

For further information please contact ()
Steps To ReproduceCreate a survey
Create a group
Create one or 2 question

Click on the preview icon
Additional InformationThink it's best to allways call $force_refresh in create filed map and Expression Manager for preview group

Maybe we can set dirty flags if previewgroup is set ?
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID120711
BrowserFF12
Database & DB-VersionMysql 5
Operating System (Server)debian/linux
Webserver software & versionapache
PHP VersionPHP Version 5.3
Attached Files

- Relationships

-  Notes
User avatar (19870)
DenisChenu (developer)
2012-07-20 12:29

We have already SetDirtyFlag() in database for insertquestion. Thene there are another session cache before EM.

Denis
User avatar (20121)
TMSWhite (reporter)
2012-08-03 05:08

I can't reproduce this. I'm creating a survey in English with English admin mode.

Please attach a sample survey that demonstrates this problem.
User avatar (20124)
DenisChenu (developer)
2012-08-03 11:23

Importing a survey don't do the bug.

I test again:
- Create a survey
- Create a group
- Create one question
- Click on the preview GROUP icon

If i click on preview question and after preview group : it's OK.

Maybe it's session name ?

<code>
Notice: Undefined index: language in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/index.php on line 1661 Notice: Undefined index: usecaptcha in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/index.php on line 1668 Notice: Undefined index: language in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/index.php on line 2005 Notice: Undefined index: name in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/replacements.php on line 736

Notice: Undefined index: name in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/replacements.php on line 736
Notice: Undefined index: adminname in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/index.php on line 2067 Notice: Undefined index: adminemail in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/index.php on line 2068 Notice: Undefined index: adminemail in /home/sondages.pro/htdocs/limesurvey_GIT/LimeSurvey/index.php on line 2069



This survey does not yet have any questions and cannot be tested or completed.

For further information please contact ()


</code>
User avatar (20187)
TMSWhite (reporter)
2012-08-04 13:28

I've tried following the directions several times and cannot reproduce the problem. Can anyone else reproduce this?
User avatar (20225)
abita1 (reporter)
2012-08-06 14:48

I can't reproduce, either, but note that Bug 6426 [see description] has a similar quirky cure path.
User avatar (20341)
DenisChenu (developer)
2012-08-10 15:16
edited on: 2012-08-10 15:16

Hello,

Think it's a bad $_SESSION['s_lang']:

1st : just open Your browser (don't don anything before)
I connected in admin/french (fr)
Add a french survey (fr)
Add a group
Add a question

Launch preview group:
$_SESSION['s_lang']=='en' before $clang, then no answer/no question no text ....

Mazi : can you test in de please ?

(After : you can give to me)

User avatar (20343)
Mazi (developer)
2012-08-10 16:16

Denis, can you attach your test survey so I will use the same survey settings. I will then delete all groups and create a new one as suggested for testing.
User avatar (20344)
DenisChenu (developer)
2012-08-10 16:52
edited on: 2012-08-10 16:53

It's not for A survey, it's for whole survey.
Seeting:
config.php
$defaultlang = 'en';

Admin lang !='en'
Survey lang !='en'

Then see the error.

But i found it ;)
https://github.com/LimeSurvey/LimeSurvey/commit/f6ac3941d59fbb18d5a6432dc03da0f31e7d4b40 [^]

User avatar (20345)
DenisChenu (developer)
2012-08-10 16:57

Commits:
http://git.io/YqYrsA [^] (Base 1.92)
http://git.io/X-EELA [^] (Yii)
User avatar (20351)
DenisChenu (developer)
2012-08-11 01:20

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=9322 [^]
User avatar (20352)
DenisChenu (developer)
2012-08-11 01:46

Fix committed to Yii branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=9323 [^]

- Related Changesets
LimeSurvey: master 188bdc7e
Timestamp: 2012-08-10 16:17:06
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Dev: Fix 06319 : Use existing function
mod - common_functions.php Diff ] File ]
LimeSurvey: Yii ce962efd
Timestamp: 2012-08-10 16:43:07
Author: DenisChenu
Committer: Denis Chenu
Details ] Diff ]
Dev : Fix 06319 ( language are not set under some condition) Use existing function
mod - application/helpers/frontend_helper.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2012-07-11 20:49 DenisChenu New Issue
2012-07-18 15:26 c_schmitz Assigned To => TMSWhite
2012-07-18 15:26 c_schmitz Status new => assigned
2012-07-20 12:29 DenisChenu Note Added: 19870
2012-08-03 05:08 TMSWhite Note Added: 20121
2012-08-03 05:08 TMSWhite Assigned To TMSWhite =>
2012-08-03 05:08 TMSWhite Status assigned => feedback
2012-08-03 11:23 DenisChenu Note Added: 20124
2012-08-03 11:23 DenisChenu Status feedback => new
2012-08-04 12:21 Mazi Assigned To => TMSWhite
2012-08-04 12:21 Mazi Status new => assigned
2012-08-04 13:28 TMSWhite Note Added: 20187
2012-08-04 13:28 TMSWhite Assigned To TMSWhite =>
2012-08-04 13:28 TMSWhite Status assigned => feedback
2012-08-06 14:48 abita1 Note Added: 20225
2012-08-10 15:16 DenisChenu Note Added: 20341
2012-08-10 15:16 DenisChenu Status feedback => new
2012-08-10 15:16 DenisChenu Assigned To => Mazi
2012-08-10 15:16 DenisChenu Status new => assigned
2012-08-10 15:16 DenisChenu Note Edited: 20341 View Revisions
2012-08-10 16:16 Mazi Note Added: 20343
2012-08-10 16:52 DenisChenu Note Added: 20344
2012-08-10 16:53 DenisChenu Note Edited: 20344 View Revisions
2012-08-10 16:57 DenisChenu Note Added: 20345
2012-08-10 16:57 DenisChenu Status assigned => resolved
2012-08-10 16:57 DenisChenu Fixed in Version => 1.92+
2012-08-10 16:57 DenisChenu Resolution open => fixed
2012-08-10 16:57 DenisChenu Assigned To Mazi => DenisChenu
2012-08-11 01:20 DenisChenu Changeset attached => LimeSurvey master 188bdc7e
2012-08-11 01:20 DenisChenu Note Added: 20351
2012-08-11 01:46 DenisChenu Changeset attached => LimeSurvey Yii ce962efd
2012-08-11 01:46 DenisChenu Note Added: 20352
2012-08-16 10:35 c_schmitz Fixed in Version 1.92+ => 2.00RC9
2012-08-16 10:35 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker