LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
05534Bug reports[All Projects] Tokenspublic2011-10-27 14:112011-11-08 18:56
Reporterhalliballi123 
Assigned Toc_schmitz 
PriorityurgentSeveritymajor 
StatusclosedResolutionfixed 
Product Version1.91+ 
Target VersionFixed in Version1.91+ 
Summary05534: Mail invitation is sent several times and with incorrect content
DescriptionI have the latest update installed.

Today I sent invitations to test my survey.
There is something wrong with the loop.

1 ) My first participant of the survey recieved as many invitation mails as there are participants in the survey.
2 ) My last participant got one invitation e-mail.
3 ) in the "to" field of the mail there are all recipients (until the position of the current recipient in the users list) not only the one that should be the recipient. That means the first user mail has only one recipient and the content of the mail is for him. The mail for the second participant is addressed to the first and the second participant but the content is for the second participant.
The mail for the 3rd participant is addressed to participant one, two and three.

So the problem is that the address of the invitation mail is not correctly calculated. Every round the current address is added to the ones before.
Steps To ReproduceCreate Survey, add users and send invitations
Additional InformationProblem is as well that people get the tokens of other users as well and their names.
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID11228
BrowserFirefox / Internet Explorer 8
Database & DB-VersionmySQL 5.1.56
Operating System (Server)gentoo Linux
Webserver software & versionApache 20051115
PHP VersionPHP Version 5.3.8-pl0-gentoo
Attached Files? file icon limesurvey_survey_76195.lss [^] (18,328 bytes) 2011-10-27 14:16
csv file icon tokens_76195.csv [^] (354 bytes) 2011-10-27 14:17

- Relationships

-  Notes
User avatar (16545)
sp00ky (reporter)
2011-10-27 15:05

Witch method do you use? PHP, SMTP?
User avatar (16546)
halliballi123 (reporter)
2011-10-27 15:14

Sorry, I forgot to give you that information

E-mail method: SMTP
User avatar (16550)
halliballi123 (reporter)
2011-10-28 09:53

Can I change the topic? It should be something like

"Invitation is sent to incorrect recipients"


This is critical in my opinion, because some recipients can answer using the token of another recipient !!!
User avatar (16551)
sp00ky (reporter)
2011-10-28 10:31

Everything is fine at my server (11232)...
Try to upgrade to 11232... c_schmitz fixed some issue at 11231:
http://limesurvey.svn.sourceforge.net/viewvc/limesurvey?view=revision&revision=11231 [^]
User avatar (16552)
halliballi123 (reporter)
2011-10-28 10:42

Thank you, I have not seen that there is a newer version than mine. Sorry for the inconvenience.
I have to try to use the latest version
User avatar (16553)
halliballi123 (reporter)
2011-10-28 11:04

OK, the latest Version build 11232 has fixed that bug.
Sorry for placing this bug report.
And thank you a lot for your help
User avatar (16554)
Mazi (developer)
2011-10-28 13:02

According to the user this issue is already fixed.
User avatar (16634)
c_schmitz (administrator)
2011-11-08 18:56

New version released.

- Issue History
Date Modified Username Field Change
2011-10-27 14:11 halliballi123 New Issue
2011-10-27 14:16 halliballi123 File Added: limesurvey_survey_76195.lss
2011-10-27 14:17 halliballi123 File Added: tokens_76195.csv
2011-10-27 15:05 sp00ky Note Added: 16545
2011-10-27 15:14 halliballi123 Note Added: 16546
2011-10-28 09:53 halliballi123 Note Added: 16550
2011-10-28 10:31 sp00ky Note Added: 16551
2011-10-28 10:42 halliballi123 Note Added: 16552
2011-10-28 11:04 halliballi123 Note Added: 16553
2011-10-28 13:02 Mazi Note Added: 16554
2011-10-28 13:02 Mazi Status new => resolved
2011-10-28 13:02 Mazi Fixed in Version => 1.91+
2011-10-28 13:02 Mazi Resolution open => fixed
2011-10-28 13:02 Mazi Assigned To => c_schmitz
2011-11-08 18:56 c_schmitz Note Added: 16634
2011-11-08 18:56 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker