LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
04895User patchesSurvey at runtimepublic2011-01-22 18:202012-06-21 13:23
ReporterDenisChenu 
Assigned Toc_schmitz 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version1.91 
Target Version1.91Fixed in Version1.91 
Summary04895: Allow multi Quota for List (radio) question type and other single select
DescriptionWith Quota we test if each arte equal of the quota question.

the test are
( questisXgidXqidA = QuotaValue1 ) AND ( questisXgidXqidB = QuotaValue2 )

It's OK for a lot of quota, but not for the same questisXgidXqid .

You can never have
( questisXgidXqidA = QuotaValue1 ) AND ( questisXgidXqidA = QuotaValue2 )

This patch offer the possibility to have OR condition in quota.
if questisXgidXqid are the same, then it put OR, else AND.

( questisXgidXqidA = QuotaValue1 OR questisXgidXqidA = QuotaValue2 ) AND ( questisXgidXqidB = QuotaValue2 )

Patch for 9710 svn version
Steps To ReproduceImport survey included, quota can't be accessed because there are for the same list radio question.
(sorry survey in french)
Additional InformationI can integrate for 1.91 or see for 1.92. But i think it can be good for 1.91.

:)
TagsNo tags attached.
LimeSurvey build number OR git commit ID9710
Attached Files? file icon limesurvey_survey_quota.lss [^] (23,462 bytes) 2011-01-22 18:20
diff file icon patch_04895.diff [^] (5,547 bytes) 2011-01-22 18:28 [Show Content]

- Relationships

-  Notes
User avatar (14571)
c_schmitz (administrator)
2011-03-28 02:00

Thank you!

- Issue History
Date Modified Username Field Change
2011-01-22 18:20 DenisChenu New Issue
2011-01-22 18:20 DenisChenu File Added: limesurvey_survey_quota.lss
2011-01-22 18:22 DenisChenu File Added: patch_04895.diff
2011-01-22 18:28 DenisChenu File Deleted: patch_04895.diff
2011-01-22 18:28 DenisChenu File Added: patch_04895.diff
2011-03-28 02:00 c_schmitz Status new => resolved
2011-03-28 02:00 c_schmitz Fixed in Version => 1.91
2011-03-28 02:00 c_schmitz Resolution open => fixed
2011-03-28 02:00 c_schmitz Assigned To => c_schmitz
2011-03-28 02:00 c_schmitz Note Added: 14571
2012-06-21 13:23 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker