LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
04752Bug reports[All Projects] Otherpublic2010-11-19 19:122010-11-28 02:55
ReporterResearchOnBlogs 
Assigned Toc_schmitz 
PrioritynormalSeverityminor 
StatusclosedResolutionfixed 
Product Version1.90+ 
Target VersionFixed in Version1.90+ 
Summary04752: Step to lastpage
DescriptionHi there,
about one year ago you build in a function, that force the user, to his last page (group) if he return to the survey later again, to finish it (in survey table: lastpage). Now I'm wondering, if this function is still working? I tried it twice on two surveys, without success...

I turned on:
Enable token-based response persistence? ON
Anonymous answers? This survey is NOT anonymous.

"Allow saves?" we don't need for this function for "lastpage".. right? (I don't want save the results! - shouldn't the "lastpage" not to be a kind of "auto save"?

It seems, that this function is not working anymore..

Cheers Kai
I will donate to the project if issue is resolved within 48 hrsNo
LimeSurvey build number OR git commit ID9459
Browsersql
Database & DB-Versionphp 5.2
Operating System (Server)linux
Webserver software & versionapache
PHP Versionphp 5.2
Attached Files? file icon index.php [^] (124,934 bytes) 2010-11-23 12:14

- Relationships

-  Notes
User avatar (13560)
c_schmitz (administrator)
2010-11-20 19:33

Works like a charm here. What link are you using to re-enter the survey?
User avatar (13566)
c_schmitz (administrator)
2010-11-22 13:32

?
User avatar (13570)
ResearchOnBlogs (developer)
2010-11-22 14:07

.. tried some more tests...

1. /limesurvey/index.php?sid=xxxx -> no step to last page - NOT WORKING
2. /limesurveysurvey/xxx/lang-en/tk-xxx (from invitation email) -> IS WORKING
User avatar (13576)
c_schmitz (administrator)
2010-11-22 22:32

No problem here either.
Are you sure you closed the browser in between to clear out any existing sessions?
User avatar (13579)
ResearchOnBlogs (developer)
2010-11-22 23:27

Ok that's the problem.. the session! Is it possible to kill the session without closing the browser? Maybe by leaving the path.
User avatar (13580)
c_schmitz (administrator)
2010-11-22 23:31

Only by adding the newtest=Y param to the path (that won't work with the Short URL)
User avatar (13582)
ResearchOnBlogs (developer)
2010-11-23 11:55

Hi Carsten,
sorry for reopen..
think the prob. is simalar to this..
have a look on this: http://bugs.limesurvey.org/view.php?id=2982 [^]

Wrote something into forum:

http://www.limesurvey.org/de/support/hilfe-foren/6-development/52767-limesurvey-in-other-website#52772 [^]
User avatar (13583)
c_schmitz (administrator)
2010-11-23 12:15

Attached fixed file. Please report if that resolved the &newtest issue.
User avatar (13586)
ResearchOnBlogs (developer)
2010-11-23 13:06

thanx for the patch.. It seems it works almost
if I use this and your new index.html:

$tokentable = $dbprefix."tokens_".$sid;
$location = $rooturl;
$location .= '?sid='.$sid;
$location .= '&token='.$token; // problem beim Sprung??
$location .= '&newtest=Y';

Now I got a page/group BEFORE my last visited page/group - maybe we need a +1 somewhere..
User avatar (13650)
c_schmitz (administrator)
2010-11-28 02:55

Well, that is the intended behaviour. Because the page where you are currently on when you are closing the browser isn't submitted and therefore not saved.

- Issue History
Date Modified Username Field Change
2010-11-19 19:12 ResearchOnBlogs New Issue
2010-11-20 19:33 c_schmitz Note Added: 13560
2010-11-20 19:33 c_schmitz Assigned To => c_schmitz
2010-11-20 19:33 c_schmitz Status new => feedback
2010-11-22 13:32 c_schmitz Note Added: 13566
2010-11-22 14:07 ResearchOnBlogs Note Added: 13570
2010-11-22 14:07 ResearchOnBlogs Status feedback => assigned
2010-11-22 22:32 c_schmitz Note Added: 13576
2010-11-22 22:32 c_schmitz Status assigned => feedback
2010-11-22 23:27 ResearchOnBlogs Note Added: 13579
2010-11-22 23:27 ResearchOnBlogs Status feedback => assigned
2010-11-22 23:31 c_schmitz Note Added: 13580
2010-11-22 23:31 c_schmitz Status assigned => closed
2010-11-22 23:31 c_schmitz Resolution open => no change required
2010-11-23 11:55 ResearchOnBlogs Note Added: 13582
2010-11-23 11:55 ResearchOnBlogs Status closed => feedback
2010-11-23 11:55 ResearchOnBlogs Resolution no change required => reopened
2010-11-23 12:14 c_schmitz File Added: index.php
2010-11-23 12:15 c_schmitz Note Added: 13583
2010-11-23 13:06 ResearchOnBlogs Note Added: 13586
2010-11-23 13:06 ResearchOnBlogs Status feedback => assigned
2010-11-28 02:55 c_schmitz Note Added: 13650
2010-11-28 02:55 c_schmitz Status assigned => resolved
2010-11-28 02:55 c_schmitz Fixed in Version => 1.90+
2010-11-28 02:55 c_schmitz Resolution reopened => fixed
2010-11-28 02:55 c_schmitz Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker