LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
04289Bug reports[All Projects] Statisticspublic2010-04-21 20:512011-10-18 17:54
Reporterzongo 
Assigned Toc_schmitz 
PrioritylowSeveritytrivial 
StatusclosedResolutionfixed 
Product Version1.87+ 
Target Version1.90RC1Fixed in Version1.90RC3 
Summary04289: German Umlauts are not correct coded in public Statistik
DescriptionGerman Umlauts like "ö, ü, ä" are not correct coded in the public statistik. For Example: An "ü" looks like that: ü
Additional Information1. php5 runs on server throgh a modified ".htaccas" file (code: addHandler x-httpd-php5. php.). The base version of php on server is 4.4.9-0.dotdeb.1

2. The same problem was already reported unter "03407 - umlauts in public statistic". Using the fixed file introduced there shows no result.

3. The problem does not appear by using the same LimeSurvey version unter XAMPP

4. Sorry for my english
I will donate to the project if issue is resolved within 48 hrs
LimeSurvey build number OR git commit ID8518
BrowserFirefox 3.6.3
Database & DB-VersionMySQL Client API version 5.0.84
Operating System (Server)Linux
Webserver software & versionApache
PHP Versionphp5
Attached Filescsv file icon limesurvey_survey_12847.csv [^] (5,088 bytes) 2010-04-21 20:51
png file icon pub_stats_umlauts-Mazi.PNG [^] (11,523 bytes) 2010-04-22 00:05


? file icon limesurvey_survey_11892-public stats test.lss [^] (15,058 bytes) 2010-07-13 02:38
jpg file icon publis_stats_umlauts.JPG [^] (60,780 bytes) 2010-07-13 02:39

- Relationships
has duplicate 04358closedc_schmitz accents badly encoded and html not parsed in graphics legend 

-  Notes
User avatar (11629)
Mazi (developer)
2010-04-22 00:05

I could reproduce the problem at the latest SVN version (see attached screen shot).

I also get the following error several times when calling the public statistics: "Deprecated: Function split() is deprecated in C:\xampp\htdocs\limeSOURCE\limesurvey\classes\pchart\pchart\pChart.class on line 289"
-> Using PHP 5.3.1
User avatar (11987)
zongo (reporter)
2010-05-26 20:30

Hello,

i´ve just learned something, what could perhaps help to fix the problem with the german umlauts. Limesurvey uses (as far as I know) basically the "UTF 8" code, but in the public statistik the signs are encoded instead of "UTF-8" with "ISO-8859-1".

If I change the code in my browser to "UTF-8", the signs are correctly encoded.

sincerely yours

Zongo
User avatar (12403)
Mazi (developer)
2010-07-13 02:37

I still run into umlaut problems when using the attached "Public statistics test" survey (ID 11892).

Error messages:
Warning: imageftbbox() [function.imageftbbox]: any2eucjp(): something happen in C:\xampp\htdocs\limeSOURCE\limesurvey_svn\classes\pchart\pchart\pChart.class on line 966

Warning: imageftbbox() [function.imageftbbox]: any2eucjp(): something happen in C:\xampp\htdocs\limeSOURCE\limesurvey_svn\classes\pchart\pchart\pChart.class on line 993

Warning: imagettftext() [function.imagettftext]: any2eucjp(): something happen in C:\xampp\htdocs\limeSOURCE\limesurvey_svn\classes\pchart\pchart\pChart.class on line 1015

Warning: imageftbbox() [function.imageftbbox]: any2eucjp(): something happen in C:\xampp\htdocs\limeSOURCE\limesurvey_svn\classes\pchart\pchart\pChart.class on line 1017

Also see attached screen shot.
User avatar (12445)
c_schmitz (administrator)
2010-07-17 21:13

Mazi, yours is a different error which I can't reproduce any way. Please issue a new bug report or try to find out what is causing it.
User avatar (16320)
Mazi (developer)
2011-09-24 00:39

Carsten, a user solved a similar problem, see http://www.limesurvey.org/en/forum/development/65761-chinese-mess-code-in-statistical-reports [^]

Can you check if this is a solution we can integrate? If not possible, simply close the ticket again.
User avatar (16449)
c_schmitz (administrator)
2011-10-18 17:54

The solution described does make no real sense to me. I don't think it is worth to followup, especially if it works on the demo version.

- Issue History
Date Modified Username Field Change
2010-04-21 20:51 zongo New Issue
2010-04-21 20:51 zongo File Added: limesurvey_survey_12847.csv
2010-04-22 00:05 Mazi Note Added: 11629
2010-04-22 00:05 Mazi File Added: pub_stats_umlauts-Mazi.PNG
2010-04-22 00:07 Mazi Status new => assigned
2010-04-22 00:07 Mazi Assigned To => c_schmitz
2010-05-21 12:27 Mazi Relationship added has duplicate 04358
2010-05-21 12:29 Mazi Target Version => 1.90RC1
2010-05-26 20:30 zongo Note Added: 11987
2010-06-02 11:56 c_schmitz Status assigned => resolved
2010-06-02 11:56 c_schmitz Fixed in Version => 1.90RC1
2010-06-02 11:56 c_schmitz Resolution open => fixed
2010-06-08 21:51 c_schmitz Status resolved => closed
2010-07-13 02:37 Mazi Note Added: 12403
2010-07-13 02:37 Mazi Status closed => feedback
2010-07-13 02:37 Mazi Resolution fixed => reopened
2010-07-13 02:38 Mazi File Added: limesurvey_survey_11892-public stats test.lss
2010-07-13 02:39 Mazi File Added: publis_stats_umlauts.JPG
2010-07-17 21:12 c_schmitz Status feedback => closed
2010-07-17 21:12 c_schmitz Resolution reopened => fixed
2010-07-17 21:12 c_schmitz Fixed in Version 1.90RC1 => 1.90RC3
2010-07-17 21:13 c_schmitz Note Added: 12445
2010-07-17 21:13 c_schmitz Status closed => resolved
2010-07-20 22:16 c_schmitz Status resolved => closed
2011-09-24 00:39 Mazi Note Added: 16320
2011-09-24 00:39 Mazi Status closed => feedback
2011-09-24 00:39 Mazi Resolution fixed => reopened
2011-09-24 00:39 Mazi Status feedback => assigned
2011-10-18 17:54 c_schmitz Note Added: 16449
2011-10-18 17:54 c_schmitz Status assigned => closed
2011-10-18 17:54 c_schmitz Resolution reopened => fixed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker