LimeSurvey issue tracker
Registration

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
03689Bug reports[All Projects] Survey takingpublic2009-09-16 14:352009-09-19 03:15
Reporteruser4909 
Assigned Toc_schmitz 
PrioritynormalSeveritymajor 
StatusclosedResolutionno change required 
Product Version1.85+ 
Target VersionFixed in Version 
Summary03689: It reports "Deprecated: mktime() [function.mktime]: The is_dst parameter is deprecated in /opt/...
DescriptionAfter users have completed the survey, the redirected page would say some notification at the head of the page:

Deprecated: mktime() [function.mktime]: The is_dst parameter is deprecated in /opt/lampp/htdocs/limesurvey/classes/adodb/adodb-time.inc.php on line 732

Deprecated: gmmktime() [function.gmmktime]: The is_dst parameter is deprecated in /opt/lampp/htdocs/limesurvey/classes/adodb/adodb-time.inc.php on line 732

Deprecated: Function eregi() is deprecated in /opt/lampp/htdocs/limesurvey/classes/phpmailer/class.phpmailer.php on line 592
I will donate to the project if issue is resolved within 48 hrs
LimeSurvey build number OR git commit ID7636
BrowserFirefox-3.0.14 on Linux
Database & DB-Versionmysql Ver 14.14 Distrib 5.1.37, for unknown-linux-gnu (x86_64) using EditLine wrapper
Operating System (Server)Ubuntu 8.10(32 bit), Ubuntu 9.04(32 bit), RHEL-4.0
Webserver software & versionServer version: Apache/2.2.12 (Unix) Server built: Jul 30 2009 10:16:29
PHP VersionPHP 5.3.0 (cli) (built: Jul 30 2009 10:44:08) Copyright (c) 1997-2009 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies
Attached Files

- Relationships

-  Notes
User avatar (09584)
c_schmitz (administrator)
2009-09-17 18:09

This is not a bug but a wrong configuration setting of your PHP in connection with a relatively new PHP version.

In production mode you should set PHP not to display any errors to prevent disclosure. Normally you can do that by settings display_errors to 0 in your php.ini.
(09598)
user372
2009-09-18 02:27

I can reproduce the error on my normal installation too, but my PHP version is 5.2.10.
Strict Standards: mktime() [function.mktime]: The is_dst parameter is deprecated in /home/.sites/962/site989/web/limesurvey/classes/adodb/adodb-time.inc.php on line 732

Strict Standards: gmmktime() [function.gmmktime]: The is_dst parameter is deprecated in /home/.sites/962/site989/web/limesurvey/classes/adodb/adodb-time.inc.php on line 732

Which php setting is in your opinion wrong at my provider?
(09599)
user4909
2009-09-18 04:17

I have resolved this issue. We need to use Production Value for "error_reporting" in "php.ini":
error_reporting = E_ALL & ~E_DEPRECATED

I have tested it and it works as expected.

- Issue History
Date Modified Username Field Change
2009-09-16 14:35 user4909 New Issue
2009-09-16 14:35 user4909 Status new => assigned
2009-09-16 14:35 user4909 Assigned To => user372
2009-09-16 14:35 user4909 Build Number => 7636
2009-09-16 14:35 user4909 Browser => Firefox-3.0.14 on Linux
2009-09-16 14:35 user4909 Database & DB-Version => mysql Ver 14.14 Distrib 5.1.37, for unknown-linux-gnu (x86_64) using EditLine wrapper
2009-09-16 14:35 user4909 Operating System (Server) => Ubuntu 8.10(32 bit), Ubuntu 9.04(32 bit), RHEL-4.0
2009-09-16 14:35 user4909 Webserver => Server version: Apache/2.2.12 (Unix) Server built: Jul 30 2009 10:16:29
2009-09-16 14:35 user4909 PHP Version => PHP 5.3.0 (cli) (built: Jul 30 2009 10:44:08) Copyright (c) 1997-2009 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies
2009-09-17 18:09 c_schmitz Note Added: 09584
2009-09-17 18:09 c_schmitz Status assigned => closed
2009-09-17 18:09 c_schmitz Resolution open => no change required
2009-09-18 02:27 user372 Note Added: 09598
2009-09-18 02:27 user372 Status closed => feedback
2009-09-18 02:27 user372 Resolution no change required => reopened
2009-09-18 02:28 user372 Status feedback => assigned
2009-09-18 02:28 user372 Assigned To user372 => c_schmitz
2009-09-18 04:17 user4909 Note Added: 09599
2009-09-19 03:15 c_schmitz Status assigned => closed
2009-09-19 03:15 c_schmitz Resolution reopened => no change required
2010-10-25 00:18 c_schmitz Category Survey at Runtime => Survey taking


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker